Services Unavailable

Major incident Hosting Providers Windows 10 Home Ubuntu 18.04.4 LTS
2020-11-12 03:09 CEST · 28 minutes, 38 seconds

Updates

Resolved

Our engineering team has resolved this issue.

November 12, 2020 · 03:37 CEST
Investigating

Restored our services. We are currently investigating with the engineering team.

November 12, 2020 · 03:35 CEST
Investigating

Our engineering team is online and currently investigating on this issue.

November 12, 2020 · 03:10 CEST

← Back